commit d8b95554be6b3073679f58751f422c13157cb2f5
parent 3b555aedd71f7565f2ccc47d363c54ffb3de3889
Author: Hiltjo Posthuma <hiltjo@codemadness.org>
Date: Sat, 31 May 2014 18:56:00 +0200
add testdisk, fuse
improve style of ntfs3g, e2fsprogs and ncurses
Signed-off-by: Hiltjo Posthuma <hiltjo@codemadness.org>
Diffstat:
14 files changed, 150 insertions(+), 8 deletions(-)
diff --git a/e2fsprogs/depsinc.mk b/e2fsprogs/depsinc.mk
@@ -1,4 +1,7 @@
<$e2fsprogs_DEPDIR/v.mk
-DEPS_CFLAGS = $DEPS_CFLAGS -I$e2fsprogs_DEPDIR/e2fsprogs-$v/lib
-DEPS_LDFLAGS = $DEPS_LDFLAGS -L$e2fsprogs_DEPDIR/e2fsprogs-$v/lib/uuid -luuid
+e2fsprogs_includedir = ${e2fsprogs_DEPDIR}/e2fsprogs-$v/lib
+e2fsprogs_libdir = ${e2fsprogs_DEPDIR}/e2fsprogs-$v/lib/uuid
+
+DEPS_CFLAGS = $DEPS_CFLAGS -I${e2fsprogs_includedir}
+DEPS_LDFLAGS = $DEPS_LDFLAGS -L${e2fsprogs_libdir} -luuid
diff --git a/e2fsprogs/e2fsprogs.mk b/e2fsprogs/e2fsprogs.mk
@@ -3,9 +3,13 @@ TARG = e2fsprogs
<$mkbuild/mk.common-noinst
e2fsprogs:QV:
- CC="$CC -static" CFLAGS="-D__uint64_t=u_int64_t" ./configure --prefix="" \
- --bindir="$BINDIR" --sbindir="$BINDIR" --libexecdir="$BINDIR" \
- --mandir="/share/man" --disable-nls
+ CC="$CC -static" CFLAGS="-D__uint64_t=u_int64_t" ./configure \
+ --prefix="" \
+ --disable-nls \
+ --bindir="$BINDIR" \
+ --sbindir="$BINDIR" \
+ --libexecdir="$BINDIR" \
+ --mandir="$prefix/share/man"
make -j$nprocs
install:QV:
diff --git a/fuse/checksums b/fuse/checksums
@@ -0,0 +1 @@
+03f43f88694ec7e039ff3579a8e76349b5a5a05872c55901fc1d9ee53dbb6b1e69f6dd0005b620f3b5ead0b14da8eeb31d46b922d10f88f4e3f830aa47e8162c fuse-2.9.3.tar.gz
diff --git a/fuse/depsinc.mk b/fuse/depsinc.mk
@@ -0,0 +1,6 @@
+<$fuse_DEPDIR/v.mk
+
+fuse_libdir = $fuse_DEPDIR/fuse-$v/liba/lib
+fuse_includedir = $fuse_DEPDIR/fuse-$v/liba/include
+DEPS_CFLAGS = $DEPS_CFLAGS -I${fuse_includedir}
+DEPS_LDFLAGS = $DEPS_LDFLAGS -L${fuse_libdir} -lfuse
diff --git a/fuse/fuse-include.patch b/fuse/fuse-include.patch
@@ -0,0 +1,55 @@
+diff -uri fuse-2.9.3/util/fusermount.c fuse-2.9.3/util/fusermount.c
+--- fuse-2.9.3/util/fusermount.c 2013-07-01 09:25:36.000000000 +0200
++++ fuse-2.9.3/util/fusermount.c 2014-05-31 16:10:12.430449090 +0200
+@@ -21,6 +21,7 @@
+ #include <fcntl.h>
+ #include <pwd.h>
+ #include <mntent.h>
++#include <paths.h>
+ #include <sys/wait.h>
+ #include <sys/stat.h>
+ #include <sys/mount.h>
+diff -uri fuse-2.9.3/util/mount_util.c fuse-2.9.3/util/mount_util.c
+--- fuse-2.9.3/util/mount_util.c 2013-07-01 10:02:18.000000000 +0200
++++ fuse-2.9.3/util/mount_util.c 2014-05-31 16:11:53.383444957 +0200
+@@ -19,6 +19,7 @@
+ #ifndef __NetBSD__
+ #include <mntent.h>
+ #endif
++#include <paths.h>
+ #include <sys/stat.h>
+ #include <sys/wait.h>
+ #include <sys/mount.h>
+diff -uri fuse-2.9.3/lib/fuse.c fuse-2.9.3/lib/fuse.c
+--- fuse-2.9.3/lib/fuse.c 2013-07-01 09:40:39.000000000 +0200
++++ fuse-2.9.3/lib/fuse.c 2014-05-31 15:36:49.281531093 +0200
+@@ -37,6 +37,7 @@
+ #include <sys/uio.h>
+ #include <sys/time.h>
+ #include <sys/mman.h>
++#include <sys/file.h>
+
+ #define FUSE_NODE_SLAB 1
+
+diff -uri fuse-2.9.3/lib/fuse_lowlevel.c fuse-2.9.3/lib/fuse_lowlevel.c
+--- fuse-2.9.3/lib/fuse_lowlevel.c 2013-07-01 09:40:39.000000000 +0200
++++ fuse-2.9.3/lib/fuse_lowlevel.c 2014-05-31 15:36:49.283531093 +0200
+@@ -24,6 +24,7 @@
+ #include <limits.h>
+ #include <errno.h>
+ #include <assert.h>
++#include <sys/file.h>
+
+ #ifndef F_LINUX_SPECIFIC_BASE
+ #define F_LINUX_SPECIFIC_BASE 1024
+diff -uri fuse-2.9.3/lib/mount_util.c fuse-2.9.3/lib/mount_util.c
+--- fuse-2.9.3/lib/mount_util.c 2013-07-01 09:25:36.000000000 +0200
++++ fuse-2.9.3/lib/mount_util.c 2014-05-31 15:36:49.284531093 +0200
+@@ -16,6 +16,7 @@
+ #include <errno.h>
+ #include <fcntl.h>
+ #include <limits.h>
++#include <paths.h>
+ #ifndef __NetBSD__
+ #include <mntent.h>
+ #endif
diff --git a/fuse/fuse.mk b/fuse/fuse.mk
@@ -0,0 +1,23 @@
+TARG = fuse
+INSTALL_BIN = \
+ util/mount.fuse \
+ util/fusermount \
+ util/ulockmgr_server
+INSTALL_MAN1 = `{ ls -1 doc/*.1 }
+INSTALL_MAN8 = `{ ls -1 doc/*.8 }
+
+<$mkbuild/mk.common
+
+fuse:QV:
+ ./configure \
+ --prefix="$prefix" \
+ --mandir="$ROOT/share/man" \
+ --disable-shared \
+ --enable-util \
+ --enable-lib \
+ --enable-static
+ make -j$nprocs LDFLAGS="-all-static $LDFLAGS"
+ # for use as a dependency.
+ make -j$nprocs install DESTDIR=`pwd`/liba LDFLAGS="-all-static $LDFLAGS"
+ # remove .la files for now ?
+ find `pwd`/liba -iname "*.la" -exec rm {} \;
diff --git a/fuse/mkfile b/fuse/mkfile
@@ -0,0 +1,8 @@
+<$mkbuild/mk.3rdparty
+
+<v.mk
+src = fuse-$v
+url = http://softlayer-ams.dl.sourceforge.net/project/fuse/fuse-2.X/$v/fuse-$v.tar.gz
+mkfile = ../fuse.mk
+patches = \
+ ../fuse-include.patch
diff --git a/fuse/v.mk b/fuse/v.mk
@@ -0,0 +1 @@
+v = 2.9.3
diff --git a/ncurses/depsinc.mk b/ncurses/depsinc.mk
@@ -1,4 +1,7 @@
<$ncurses_DEPDIR/v.mk
-DEPS_CFLAGS = $DEPS_CFLAGS -I$ncurses_DEPDIR/ncurses-$v/include
-DEPS_LDFLAGS = $DEPS_LDFLAGS -L$ncurses_DEPDIR/ncurses-$v/lib
+ncurses_includedir = ${ncurses_DEPDIR}/ncurses-$v/include
+ncurses_libdir = ${ncurses_DEPDIR}/ncurses-$v/lib
+
+DEPS_CFLAGS = $DEPS_CFLAGS -I${ncurses_includedir}
+DEPS_LDFLAGS = $DEPS_LDFLAGS -L${ncurses_libdir}
diff --git a/ntfs3g/ntfs3g.mk b/ntfs3g/ntfs3g.mk
@@ -34,4 +34,7 @@ ntfs3g:QV:
--enable-really-static \
--enable-mount-helper \
--enable-static
- make -j$nprocs LDFLAGS="-all-static $LDFLAGS"
+ make -j$nprocs install \
+ LDFLAGS="-all-static $LDFLAGS" DESTDIR="`pwd`/liba"
+ # remove .la files for now ?
+ find "`pwd`/liba" -iname "*.la" -exec rm {} \;
diff --git a/testdisk/checksums b/testdisk/checksums
@@ -0,0 +1 @@
+f479c7863e1a39bf747a0b73b37eba1016e4762373b9b68747fed6141aa8faa7703c89dddc975df18904759292cd7d333ca0619eacb3c1eea76790a917e95774 testdisk-6.14.tar.bz2
diff --git a/testdisk/mkfile b/testdisk/mkfile
@@ -0,0 +1,6 @@
+<$mkbuild/mk.3rdparty
+
+<v.mk
+src = testdisk-$v
+url = http://www.cgsecurity.org/testdisk-$v.tar.bz2
+mkfile = ../testdisk.mk
diff --git a/testdisk/testdisk.mk b/testdisk/testdisk.mk
@@ -0,0 +1,27 @@
+TARG = testdisk
+DEPS = ncurses e2fsprogs ntfs3g
+
+<$mkbuild/mk.common-noinst
+
+testdisk:QV:
+ export CFLAGS="$CFLAGS $DEPS_CFLAGS"
+ export LDFLAGS="$LDFLAGS $DEPS_LDFLAGS"
+ CC="$CC" ./configure \
+ --prefix="$prefix" \
+ --mandir="$ROOT/share/man" \
+ --disable-qt \
+ --without-iconv \
+ --without-reiserfs \
+ --without-ewf \
+ --without-jpeg \
+ --without-ntfs \
+ --with-ext2fs-lib="${e2fsprogs_libdir}" \
+ --with-ext2fs-includes="${e2fsprogs_includedir}" \
+ --with-ntfs3g-lib="${ntfs3g_libdir}" \
+ --with-ntfs3g-includes="${ntfs3g_includedir}" \
+ --with-ncurses-lib="${ncurses_libdir}" \
+ --with-ncurses-includes="${ncurses_includedir}"
+ make -j$nprocs
+
+install:QV:
+ make -j$nprocs install DESTDIR="$ROOT"
diff --git a/testdisk/v.mk b/testdisk/v.mk
@@ -0,0 +1 @@
+v = 6.14