commit 3b555aedd71f7565f2ccc47d363c54ffb3de3889
parent ff8d2871f4ef84d9bafa04b151fe94a6d88c6311
Author: Hiltjo Posthuma <hiltjo@codemadness.org>
Date: Sat, 31 May 2014 17:08:31 +0200
add ntfs3g + ntfsprogs
Signed-off-by: Hiltjo Posthuma <hiltjo@codemadness.org>
Diffstat:
5 files changed, 69 insertions(+), 0 deletions(-)
diff --git a/ntfs3g/checksums b/ntfs3g/checksums
@@ -0,0 +1 @@
+7e4a5c9ac9d43dcf0d4b4085dea6703126fc4808cb9e1b7038884b20df2a8ab8f54c269d7204a279b62c5ba1127a966fd64226a8ed8f0c11667d9326c2f8fa7c ntfs-3g_ntfsprogs-2014.2.15.tgz
diff --git a/ntfs3g/mkfile b/ntfs3g/mkfile
@@ -0,0 +1,8 @@
+<$mkbuild/mk.3rdparty
+
+<v.mk
+src = ntfs-3g_ntfsprogs-$v
+url = http://tuxera.com/opensource/ntfs-3g_ntfsprogs-$v.tgz
+mkfile = ../ntfs3g.mk
+patches = \
+ ../ntfs3g-include.patch
diff --git a/ntfs3g/ntfs3g-include.patch b/ntfs3g/ntfs3g-include.patch
@@ -0,0 +1,22 @@
+diff -uri ntfs-3g_ntfsprogs-2014.2.15/libfuse-lite/fusermount.c patched/libfuse-lite/fusermount.c
+--- ntfs-3g_ntfsprogs-2014.2.15/libfuse-lite/fusermount.c 2014-02-15 15:07:52.000000000 +0100
++++ patched/libfuse-lite/fusermount.c 2014-05-31 16:39:30.783377108 +0200
+@@ -19,6 +19,7 @@
+ #include <errno.h>
+ #include <fcntl.h>
+ #include <pwd.h>
++#include <paths.h>
+
+ #ifdef __SOLARIS__
+ #include <sys/mnttab.h>
+diff -uri ntfs-3g_ntfsprogs-2014.2.15/libfuse-lite/mount_util.c patched/libfuse-lite/mount_util.c
+--- ntfs-3g_ntfsprogs-2014.2.15/libfuse-lite/mount_util.c 2014-02-15 15:07:52.000000000 +0100
++++ patched/libfuse-lite/mount_util.c 2014-05-31 16:39:20.183377542 +0200
+@@ -17,6 +17,7 @@
+ #include <limits.h>
+ #include <sys/stat.h>
+ #include <sys/wait.h>
++#include <paths.h>
+ #ifdef __SOLARIS__
+ #else /* __SOLARIS__ */
+ #include <mntent.h>
diff --git a/ntfs3g/ntfs3g.mk b/ntfs3g/ntfs3g.mk
@@ -0,0 +1,37 @@
+TARG = ntfs3g
+INSTALL_BIN = \
+ src/lowntfs-3g \
+ src/ntfs-3g \
+ src/ntfs-3g.probe \
+ src/ntfs-3g.secaudit \
+ src/ntfs-3g.usermap \
+ ntfsprogs/mkntfs \
+ ntfsprogs/ntfscat \
+ ntfsprogs/ntfsclone \
+ ntfsprogs/ntfscluster \
+ ntfsprogs/ntfscmp \
+ ntfsprogs/ntfscp \
+ ntfsprogs/ntfsfix \
+ ntfsprogs/ntfsinfo \
+ ntfsprogs/ntfslabel \
+ ntfsprogs/ntfsls \
+ ntfsprogs/ntfsresize \
+ ntfsprogs/ntfsundelete
+
+INSTALL_MAN8 = `{ ls -1 src/*.8; ls -1 ntfsprogs/*.8 }
+INSTALL_SYMLINK = \
+ mkntfs /bin/mkfs.ntfs \
+ lowntfs-3g /bin/mount.lowntfs-3g \
+ ntfs-3g /bin/mount.ntfs-3g
+
+<$mkbuild/mk.common
+
+ntfs3g:QV:
+ ./configure \
+ --prefix="$prefix" \
+ --mandir="$ROOT/share/man" \
+ --disable-shared \
+ --enable-really-static \
+ --enable-mount-helper \
+ --enable-static
+ make -j$nprocs LDFLAGS="-all-static $LDFLAGS"
diff --git a/ntfs3g/v.mk b/ntfs3g/v.mk
@@ -0,0 +1 @@
+v = 2014.2.15