commit fff8baeb18a4c24a2f8fdf3bd9f5e1587699c1f7
parent 7ac48bf81f51adccb87a0e9e44aaaf95797c04ac
Author: Hiltjo Posthuma <hiltjo@codemadness.org>
Date: Fri, 16 May 2014 17:26:47 +0000
add libpthreadstubs
Signed-off-by: Hiltjo Posthuma <hiltjo@codemadness.org>
Diffstat:
4 files changed, 27 insertions(+), 0 deletions(-)
diff --git a/libpthreadstubs/depsinc.mk b/libpthreadstubs/depsinc.mk
@@ -0,0 +1,6 @@
+<$libpthreadstubs_DEPDIR/v.mk
+
+libpthreadstubs_libdir = $libpthreadstubs_DEPDIR/libpthread-stubs-$v/lib/lib
+libpthreadstubs_includedir = $libpthreadstubs_DEPDIR/libpthread-stubs-$v/lib/include
+DEPS_CFLAGS = $DEPS_CFLAGS -I${libpthreadstubs_includedir}
+DEPS_LDFLAGS = $DEPS_LDFLAGS -L${libpthreadstubs_libdir}
diff --git a/libpthreadstubs/libpthreadstubs.mk b/libpthreadstubs/libpthreadstubs.mk
@@ -0,0 +1,14 @@
+TARG = libpthreadstubs
+
+<$mkbuild/mk.common-noinst
+
+libpthreadstubs:QV:
+ CC="$CC" ./configure \
+ --prefix="$prefix" \
+ --disable-shared \
+ --enable-static
+ make -j$nprocs
+ # install lib for use as a dependency.
+ make -j$nprocs install DESTDIR=`pwd`/lib
+ # remove .la files for now ?
+ find `pwd`/lib -iname "*.la" -exec rm {} \;
diff --git a/libpthreadstubs/mkfile b/libpthreadstubs/mkfile
@@ -0,0 +1,6 @@
+<$mkbuild/mk.3rdparty
+
+<v.mk
+src = libpthread-stubs-$v
+url = http://xcb.freedesktop.org/dist/libpthread-stubs-$v.tar.bz2
+mkfile = ../libpthreadstubs.mk
diff --git a/libpthreadstubs/v.mk b/libpthreadstubs/v.mk
@@ -0,0 +1 @@
+v = 0.3