commit e4aadfe1078ca521fd1b6dc3ea17e1112db37a95
parent e39cc7fc4e44739768b4300927c313a829a10565
Author: Hiltjo Posthuma <hiltjo@codemadness.org>
Date: Sat, 14 Jun 2014 19:56:47 +0200
add nginx and pcre
Signed-off-by: Hiltjo Posthuma <hiltjo@codemadness.org>
Diffstat:
9 files changed, 81 insertions(+), 0 deletions(-)
diff --git a/nginx/checksums b/nginx/checksums
@@ -0,0 +1 @@
+715b3aa6012e2e29f3b4e6affff4641de0958faa25c0acedb8091b0f4c8506a8912a7e507bcb1f89fc5fe0a1233ab7770dc6ed742698874f43af72b7d08e48f7 nginx-1.6.0.tar.gz
diff --git a/nginx/mkfile b/nginx/mkfile
@@ -0,0 +1,6 @@
+<$mkbuild/mk.3rdparty
+
+<v.mk
+src = nginx-$v
+url = http://nginx.org/download/nginx-$v.tar.gz
+mkfile = ../nginx.mk
diff --git a/nginx/nginx.mk b/nginx/nginx.mk
@@ -0,0 +1,37 @@
+TARG = nginx
+DEPS = openssl pcre zlib
+
+<$mkbuild/mk.common-noinst
+
+nginx:QV:
+ export CFLAGS="$CFLAGS $DEPS_CFLAGS"
+ export LDFLAGS="$LDFLAGS $DEPS_LDFLAGS"
+ # nginx incorrectly detects GNU crypt so set: -DNGX_HAVE_GNU_CRYPT_R=0"
+ export CFLAGS="$CFLAGS -DNGX_HAVE_GNU_CRYPT_R=0"
+ export CC="${CC} -static"
+ # don't rebuild pcre source, use the ports version.
+ # See: http://wiki.nginx.org/InstallOptions#Notes
+ # --with-ld-opt="-L${pcre_libdir}"
+ # --with-cc-opt="-I${pcre_includedir}"
+ ./configure \
+ --prefix=/etc/nginx \
+ --conf-path=/etc/nginx/nginx.conf \
+ --sbin-path=${prefix}/bin/nginx \
+ --error-log-path=/var/log/nginx/access.log \
+ --error-log-path=stderr \
+ --pid-path=/run/nginx.pid \
+ --lock-path=/run/lock/nginx.lock \
+ --user=http \
+ --group=http \
+ --with-file-aio \
+ --with-pcre \
+ --with-zlib=${zlib_libdir} \
+ --with-openssl=${openssl_libdir} \
+ --with-ipv6 \
+ --with-ld-opt="-L${pcre_libdir}" \
+ --with-cc-opt="-I${pcre_includedir}"
+ make -j$nprocs
+
+install:QV:
+ mkdir -p "$ROOT/run/lock"
+ make -j$nprocs install DESTDIR="$ROOT"
diff --git a/nginx/v.mk b/nginx/v.mk
@@ -0,0 +1 @@
+v = 1.6.0
diff --git a/pcre/checksums b/pcre/checksums
@@ -0,0 +1 @@
+e94c652b40de60b391e28afbddc67b5a034650f6f62027e52f2d7aef53caf5f0da9f2d4f6872d1558f965dd9d4d696e5e23d2a50f20a4fbc9f0a707fb6f55fae pcre-8.35.tar.bz2
diff --git a/pcre/depsinc.mk b/pcre/depsinc.mk
@@ -0,0 +1,10 @@
+<$pcre_DEPDIR/v.mk
+
+pcre_includedir = ${pcre_DEPDIR}/pcre-$v
+pcre_libdir = ${pcre_DEPDIR}/pcre-$v/.libs
+
+pcre_CFLAGS = -I${pcre_includedir}
+pcre_LDFLAGS = -L${pcre_libdir} -lpcre
+
+DEPS_CFLAGS = $DEPS_CFLAGS ${pcre_CFLAGS}
+DEPS_LDFLAGS = $DEPS_LDFLAGS ${pcre_LDFLAGS}
diff --git a/pcre/mkfile b/pcre/mkfile
@@ -0,0 +1,6 @@
+<$mkbuild/mk.3rdparty
+
+<v.mk
+src = pcre-$v
+url = http://cznic.dl.sourceforge.net/project/pcre/pcre/$v/pcre-$v.tar.bz2
+mkfile = ../pcre.mk
diff --git a/pcre/pcre.mk b/pcre/pcre.mk
@@ -0,0 +1,18 @@
+TARG = pcre
+DEPS = zlib
+
+<$mkbuild/mk.common-noinst
+
+pcre:QV:
+ export CFLAGS="$CFLAGS $DEPS_CFLAGS"
+ export LDFLAGS="$LDFLAGS $DEPS_LDFLAGS"
+ CC="$CC" ./configure \
+ --prefix="$prefix" \
+ --mandir="$ROOT/share/man" \
+ --disable-cpp \
+ --disable-shared \
+ --enable-static \
+ --enable-unicode-properties \
+ --enable-pcregrep-libz \
+ --enable-utf
+ make -j$nprocs
diff --git a/pcre/v.mk b/pcre/v.mk
@@ -0,0 +1 @@
+v = 8.35