commit 94e39272ca69badb392290cb26710eef9a14ae43
parent a1183f48da9eea3142e9ae998b4fc91d23889e6a
Author: Hiltjo Posthuma <hiltjo@codemadness.org>
Date: Fri, 23 May 2014 20:24:47 +0200
add mpop
Signed-off-by: Hiltjo Posthuma <hiltjo@codemadness.org>
Diffstat:
5 files changed, 218 insertions(+), 0 deletions(-)
diff --git a/mpop/checksums b/mpop/checksums
@@ -0,0 +1 @@
+fbb55bf2c83024cc4397f6f59c6977a5f77ab697bbcc508a5160cd74047b4c0b717c76970d760f413356efd0527da0c9a129f34a664fea080ad39f5cef16ccb1 mpop-1.0.29.tar.bz2
diff --git a/mpop/config.h b/mpop/config.h
@@ -0,0 +1,195 @@
+/* config.h. Generated from config.h.in by configure. */
+/* config.h.in. Generated from configure.ac by autoheader. */
+
+/* Define to 1 if translation of program messages to the user's native
+ language is requested. */
+/* #undef ENABLE_NLS */
+
+/* Define to 1 if you have the <arpa/inet.h> header file. */
+#define HAVE_ARPA_INET_H 1
+
+/* Define to 1 if you have the Mac OS X function CFLocaleCopyCurrent in the
+ CoreFoundation framework. */
+/* #undef HAVE_CFLOCALECOPYCURRENT */
+
+/* Define to 1 if you have the Mac OS X function CFPreferencesCopyAppValue in
+ the CoreFoundation framework. */
+/* #undef HAVE_CFPREFERENCESCOPYAPPVALUE */
+
+/* Define if the GNU dcgettext() function is already present or preinstalled.
+ */
+/* #undef HAVE_DCGETTEXT */
+
+/* Define to 1 if you have the `fseeko' function. */
+#define HAVE_FSEEKO 1
+
+/* Define to 1 if you have the `fseeko64' function. */
+#define HAVE_FSEEKO64 1
+
+/* Define to 1 if you have the `getpass' function. */
+#define HAVE_GETPASS 1
+
+/* Define to 1 if you have the `getservbyname' function. */
+#define HAVE_GETSERVBYNAME 1
+
+/* Define if the GNU gettext() function is already present or preinstalled. */
+/* #undef HAVE_GETTEXT */
+
+/* Define to 1 if libgnome-keyring is available */
+/* #undef HAVE_GNOME_KEYRING */
+
+/* Define if you have the iconv() function and it works. */
+/* #undef HAVE_ICONV */
+
+/* Define to 1 if you have the <inttypes.h> header file. */
+#define HAVE_INTTYPES_H 1
+
+/* Define to 1 if libgnutls is available */
+#undef HAVE_LIBGNUTLS
+
+/* Define to 1 if libgsasl is available */
+/* #undef HAVE_LIBGSASL */
+
+/* Define to 1 if libidn is available */
+#undef HAVE_LIBIDN
+
+/* Define to 1 if libssl is available */
+#define HAVE_LIBSSL 1
+
+/* Define to 1 if you have the `link' function. */
+#define HAVE_LINK 1
+
+/* Define to 1 if you have the MacOS X Keychain Services API. */
+/* #undef HAVE_MACOSXKEYRING */
+
+/* Define to 1 if you have the <memory.h> header file. */
+#define HAVE_MEMORY_H 1
+
+/* Define to 1 if you have the `mkstemp' function. */
+#define HAVE_MKSTEMP 1
+
+/* Define to 1 if you have the <netdb.h> header file. */
+#define HAVE_NETDB_H 1
+
+/* Define to 1 if you have the `sigaction' function. */
+#define HAVE_SIGACTION 1
+
+/* Define to 1 if you have the <stdint.h> header file. */
+#define HAVE_STDINT_H 1
+
+/* Define to 1 if you have the <stdlib.h> header file. */
+#define HAVE_STDLIB_H 1
+
+/* Define to 1 if you have the <strings.h> header file. */
+#define HAVE_STRINGS_H 1
+
+/* Define to 1 if you have the <string.h> header file. */
+#define HAVE_STRING_H 1
+
+/* Define to 1 if you have the `strndup' function. */
+#define HAVE_STRNDUP 1
+
+/* Define to 1 if you have the <sysexits.h> header file. */
+#define HAVE_SYSEXITS_H 1
+
+/* Define to 1 if you have the `syslog' function. */
+#define HAVE_SYSLOG 1
+
+/* Define to 1 if you have the <sys/socket.h> header file. */
+#define HAVE_SYS_SOCKET_H 1
+
+/* Define to 1 if you have the <sys/stat.h> header file. */
+#define HAVE_SYS_STAT_H 1
+
+/* Define to 1 if you have the <sys/types.h> header file. */
+#define HAVE_SYS_TYPES_H 1
+
+/* Define to 1 if you have the <sys/wait.h> header file. */
+#define HAVE_SYS_WAIT_H 1
+
+/* Define to 1 to build with TLS/SSL support */
+#define HAVE_TLS 1
+
+/* Define to 1 if you have the <unistd.h> header file. */
+#define HAVE_UNISTD_H 1
+
+/* Define to 1 if you have the `vasprintf' function. */
+#define HAVE_VASPRINTF 1
+
+/* Name of package */
+#define PACKAGE "mpop"
+
+/* Define to the address where bug reports for this package should be sent. */
+#define PACKAGE_BUGREPORT "marlam@marlam.de"
+
+/* Define to the full name of this package. */
+#define PACKAGE_NAME "mpop"
+
+/* Define to the full name and version of this package. */
+#define PACKAGE_STRING "mpop 1.0.29"
+
+/* Define to the one symbol short name of this package. */
+#define PACKAGE_TARNAME "mpop"
+
+/* Define to the home page for this package. */
+#define PACKAGE_URL "http://mpop.sourceforge.net/"
+
+/* Define to the version of this package. */
+#define PACKAGE_VERSION "1.0.29"
+
+/* Platform triplet */
+#define PLATFORM "x86_64-unknown-linux-gnu"
+
+/* Define to 1 if you have the ANSI C header files. */
+#define STDC_HEADERS 1
+
+/* Enable extensions on AIX 3, Interix. */
+#ifndef _ALL_SOURCE
+# define _ALL_SOURCE 1
+#endif
+/* Enable GNU extensions on systems that have them. */
+#ifndef _GNU_SOURCE
+# define _GNU_SOURCE 1
+#endif
+/* Enable threading extensions on Solaris. */
+#ifndef _POSIX_PTHREAD_SEMANTICS
+# define _POSIX_PTHREAD_SEMANTICS 1
+#endif
+/* Enable extensions on HP NonStop. */
+#ifndef _TANDEM_SOURCE
+# define _TANDEM_SOURCE 1
+#endif
+/* Enable general extensions on Solaris. */
+#ifndef __EXTENSIONS__
+# define __EXTENSIONS__ 1
+#endif
+
+
+/* Version number of package */
+#define VERSION "1.0.29"
+
+/* Define to 1 if the native W32 API should be used. */
+#if (defined _WIN32 || defined __WIN32__) && !defined __CYGWIN__
+#define W32_NATIVE 1
+#endif
+
+/* Enable large inode numbers on Mac OS X 10.5. */
+#ifndef _DARWIN_USE_64_BIT_INODE
+# define _DARWIN_USE_64_BIT_INODE 1
+#endif
+
+/* Number of bits in a file offset, on hosts where this is settable. */
+/* #undef _FILE_OFFSET_BITS */
+
+/* Define for large files, on AIX-style hosts. */
+/* #undef _LARGE_FILES */
+
+/* Define to 1 if on MINIX. */
+/* #undef _MINIX */
+
+/* Define to 2 if the system does not provide POSIX.1 features except with
+ this defined. */
+/* #undef _POSIX_1_SOURCE */
+
+/* Define to 1 if you need to in order for `stat' and other things to work. */
+/* #undef _POSIX_SOURCE */
diff --git a/mpop/mkfile b/mpop/mkfile
@@ -0,0 +1,6 @@
+<$mkbuild/mk.3rdparty
+
+<v.mk
+src = mpop-$v
+url = http://kent.dl.sourceforge.net/project/mpop/mpop/$v/mpop-$v.tar.bz2
+mkfile = ../mpop.mk
diff --git a/mpop/mpop.mk b/mpop/mpop.mk
@@ -0,0 +1,15 @@
+<../v.mk
+
+BIN = src/mpop
+OBJ = `{ls src/*.c | sed 's/.$/o/'}
+
+INSTALL_BIN = src/mpop
+INSTALL_MAN1 = `{ ls doc/*.1 }
+
+LOCAL_CFLAGS = \
+ -I. -include `{pwd}/../config.h -I${openssl_includedir}
+LOCAL_LDFLAGS = -L. -L${openssl_libdir} -lssl -lcrypto -lz
+
+DEPS = openssl zlib
+
+<$mkbuild/mk.default
diff --git a/mpop/v.mk b/mpop/v.mk
@@ -0,0 +1 @@
+v = 1.0.29