commit 933feb8e4c80ba502cb254ad5465db92b6e8ea7f
parent 7a51be1b8132f595d754a4cfe2971b5dc9cf76ee
Author: Hiltjo Posthuma <hiltjo@codemadness.org>
Date: Fri, 2 May 2014 17:02:22 +0000
add expat
Signed-off-by: Hiltjo Posthuma <hiltjo@codemadness.org>
Diffstat:
4 files changed, 27 insertions(+), 0 deletions(-)
diff --git a/expat/depsinc.mk b/expat/depsinc.mk
@@ -0,0 +1,6 @@
+<$expat_DEPDIR/v.mk
+
+expat_libdir = $expat_DEPDIR/expat-$v/lib/lib
+expat_includedir = $expat_DEPDIR/expat-$v/lib/include
+DEPS_CFLAGS = $DEPS_CFLAGS -I${expat_includedir}
+DEPS_LDFLAGS = $DEPS_LDFLAGS -L${expat_libdir} -lexpat
diff --git a/expat/expat.mk b/expat/expat.mk
@@ -0,0 +1,14 @@
+TARG = expat
+
+<$mkbuild/mk.common-noinst
+
+expat:QV:
+ # TODO: $ROOT/bin/xmlwf is not staticly linked.
+ ./configure --prefix="$prefix" \
+ --mandir="$ROOT/share/man" \
+ --disable-shared \
+ --enable-static
+ # make and install.
+ make -j$nprocs install DESTDIR="`pwd`/lib"
+ # remove .la files for now ?
+ find `pwd`/lib -iname "*.la" -exec rm {} \;
diff --git a/expat/mkfile b/expat/mkfile
@@ -0,0 +1,6 @@
+<$mkbuild/mk.3rdparty
+
+<v.mk
+src = expat-$v
+url = http://heanet.dl.sourceforge.net/project/expat/expat/$v/expat-$v.tar.gz
+mkfile = ../expat.mk
diff --git a/expat/v.mk b/expat/v.mk
@@ -0,0 +1 @@
+v = 2.1.0