commit 8b91ad7bf985c91553cede85a7db265bcc98659e
parent 84e6f380442456b764896b36878516f21ab8e55e
Author: Hiltjo Posthuma <hiltjo@codemadness.org>
Date: Thu, 5 Jun 2014 16:21:07 +0200
add alsautils
Signed-off-by: Hiltjo Posthuma <hiltjo@codemadness.org>
Diffstat:
7 files changed, 81 insertions(+), 0 deletions(-)
diff --git a/alsautils/alsa-utils_mixer_widget.patch b/alsautils/alsa-utils_mixer_widget.patch
@@ -0,0 +1,10 @@
+--- alsa-utils-1.0.25/alsamixer/mixer_widget.c
++++ alsa-utils-1.0.25.patched/alsamixer/mixer_widget.c
+@@ -18,6 +18,7 @@
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
++#include <strings.h>
+ #include "aconfig.h"
+ #include <stdlib.h>
+ #include <string.h>
diff --git a/alsautils/alsa-utils_portable-mutex.patch b/alsautils/alsa-utils_portable-mutex.patch
@@ -0,0 +1,27 @@
+--- alsa-utils-1.0.27.2.org/alsaloop/pcmjob.c
++++ alsa-utils-1.0.27.2/alsaloop/pcmjob.c
+@@ -62,11 +62,22 @@
+ };
+ #endif
+
+-static pthread_mutex_t pcm_open_mutex =
+- PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP;
++static pthread_once_t pcm_open_mutex_once = PTHREAD_ONCE_INIT;
++static pthread_mutex_t pcm_open_mutex;
+
++static void pcm_open_init_mutex(void)
++{
++ pthread_mutexattr_t attr;
++
++ pthread_mutexattr_init(&attr);
++ pthread_mutexattr_settype(&attr, PTHREAD_MUTEX_RECURSIVE);
++ pthread_mutex_init(&pcm_open_mutex, &attr);
++ pthread_mutexattr_destroy(&attr);
++}
++
+ static inline void pcm_open_lock(void)
+ {
++ pthread_once(&pcm_open_mutex_once, pcm_open_init_mutex);
+ if (workarounds & WORKAROUND_SERIALOPEN)
+ pthread_mutex_lock(&pcm_open_mutex);
+ }
diff --git a/alsautils/alsa-utils_signal_h.patch b/alsautils/alsa-utils_signal_h.patch
@@ -0,0 +1,11 @@
+--- alsa-utils-1.0.27.2.org/alsaloop/alsaloop.c 2013-07-23 01:48:03.592000003 +0000
++++ alsa-utils-1.0.27.2/alsaloop/alsaloop.c 2013-07-23 01:49:12.786000003 +0000
+@@ -31,7 +31,7 @@
+ #include <math.h>
+ #include <pthread.h>
+ #include <syslog.h>
+-#include <sys/signal.h>
++#include <signal.h>
+ #include "alsaloop.h"
+
+ struct loopback_thread {
diff --git a/alsautils/alsautils.mk b/alsautils/alsautils.mk
@@ -0,0 +1,21 @@
+TARG = alsautils
+DEPS = alsalib ncurses
+
+<$mkbuild/mk.common-noinst
+
+alsautils:QV:
+ #
+ export CFLAGS="$CFLAGS $DEPS_CFLAGS"
+ export LDFLAGS="$LDFLAGS $DEPS_LDFLAGS"
+ CC="$CC" ./configure \
+ --prefix="$prefix" \
+ --mandir="$ROOT/share/man" \
+ --disable-shared \
+ --disable-xmlto \
+ --disable-alsatest \
+ --disable-nls \
+ --enable-static
+ make -j$nprocs
+
+install:QV:
+ make -j$nprocs install DESTDIR="$ROOT"
diff --git a/alsautils/checksums b/alsautils/checksums
@@ -0,0 +1 @@
+c9a4943852ec1a71a5a8d2c99e1df0ba96a5d9d1196cabfdb6655f58c6a9a5a9d40dea62de019f5ed0fad0885800403c48a4a6c86b67af7fbd842097881c2bd6 alsa-utils-1.0.27.2.tar.bz2
diff --git a/alsautils/mkfile b/alsautils/mkfile
@@ -0,0 +1,10 @@
+<$mkbuild/mk.3rdparty
+
+<v.mk
+src = alsa-utils-$v
+url = ftp://ftp.alsa-project.org/pub/utils/alsa-utils-$v.tar.bz2
+mkfile = ../alsautils.mk
+patches = \
+ ../alsa-utils_mixer_widget.patch \
+ ../alsa-utils_signal_h.patch \
+ ../alsa-utils_portable-mutex.patch
diff --git a/alsautils/v.mk b/alsautils/v.mk
@@ -0,0 +1 @@
+v = 1.0.27.2