commit 87ad99d0569ac7cf17e61688124b05de4f85e48b
parent 727aec5b2168fc16db4392ab67cbefaa5471b15f
Author: Hiltjo Posthuma <hiltjo@codemadness.org>
Date: Mon, 14 Jul 2014 00:58:21 +0000
libressl: bump, less patching
Signed-off-by: Hiltjo Posthuma <hiltjo@codemadness.org>
Diffstat:
6 files changed, 16 insertions(+), 41 deletions(-)
diff --git a/libressl/checksums b/libressl/checksums
@@ -1 +1 @@
-c945f4c1b77f2b54fa2445cd5d9263545630b4fe5d603d7740ba7c1bb9f50ba5557635c073f518708c18d03af17a6ff58b104c665338fc727130c4ae95a8e3da libressl-2.0.0.tar.gz
+073e3e7260e6491f5218a26401736141d9e365fc1829e9e95a1cb1b58c627715834428b35b6b803c48b2f9014c48bedad2cdf9b106bb72430db626c91d4400ca libressl-2.0.1.tar.gz
diff --git a/libressl/libressl-entropy-nonsense.patch b/libressl/libressl-entropy-nonsense.patch
@@ -1,18 +0,0 @@
---- libressl-2.0.0.org/crypto/compat/getentropy_linux.c 2014-07-12 10:49:35.360915885 +0000
-+++ libressl-2.0.0/crypto/compat/getentropy_linux.c 2014-07-12 10:51:06.879916029 +0000
-@@ -65,7 +65,6 @@
-
- int getentropy(void *buf, size_t len);
-
--extern int main(int, char *argv[]);
- static int gotdata(char *buf, size_t len);
- static int getentropy_urandom(void *buf, size_t len);
- #ifdef CTL_MAXNAME
-@@ -338,7 +337,6 @@
- HX(sigprocmask(SIG_BLOCK, NULL, &sigset) == -1,
- sigset);
-
-- HD(main); /* an addr in program */
- HD(getentropy); /* an addr in this library */
- HD(printf); /* an addr in libc */
- p = (char *)&p;
diff --git a/libressl/libressl-glibc.patch b/libressl/libressl-glibc.patch
@@ -1,5 +1,5 @@
---- libressl-2.0.0.org/crypto/compat/issetugid_linux.c
-+++ libressl-2.0.0/crypto/compat/issetugid_linux.c
+--- crypto/compat/issetugid_linux.c.old
++++ crypto/compat/issetugid_linux.c
@@ -4,7 +4,9 @@
*/
@@ -10,7 +10,15 @@
#include <string.h>
#include <sys/types.h>
#include <unistd.h>
-@@ -33,15 +35,19 @@
+@@ -19,7 +21,6 @@
+
+ int issetugid(void)
+ {
+-#ifdef HAVE_GETAUXVAL
+ /*
+ * The API for glibc < 2.19 does not indicate if there is an error with
+ * getauxval. While it should not be the case that any 2.6 or greater
+@@ -33,14 +34,19 @@
* info: http://lwn.net/Articles/519085/
*
*/
@@ -18,25 +26,15 @@
const char *glcv = gnu_get_libc_version();
if (strverscmp(glcv, "2.19") >= 0) {
+#endif
++#ifdef HAVE_GETAUXVAL
errno = 0;
if (getauxval(AT_SECURE) == 0) {
if (errno != ENOENT) {
return 0;
}
}
++#endif
+#ifdef __GLIBC__
}
-+#endif
#endif
return 1;
- }
---- libressl-2.0.0.org/crypto/compat/getentropy_linux.c
-+++ libressl-2.0.0/crypto/compat/getentropy_linux.c
-@@ -24,7 +24,6 @@
- #include <sys/ioctl.h>
- #include <sys/resource.h>
- #include <sys/syscall.h>
--#include <sys/sysctl.h>
- #include <sys/statvfs.h>
- #include <sys/socket.h>
- #include <sys/mount.h>
diff --git a/libressl/libressl.mk b/libressl/libressl.mk
@@ -3,10 +3,6 @@ TARG = libressl
<$mkbuild/mk.common-noinst
libressl:QV:
- # remove -Werror (mostly due to __bounded__ attribute warnings,
- # which will make the build fail).
- sed -i 's@-Werror@@g' configure
- #
export CFLAGS="$CFLAGS $DEPS_CFLAGS"
export LDFLAGS="$LDFLAGS $DEPS_LDFLAGS"
#
diff --git a/libressl/mkfile b/libressl/mkfile
@@ -6,5 +6,4 @@ url = http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-$v.tar.gz
mkfile = ../libressl.mk
patches = \
- ../libressl-entropy-nonsense.patch \
- ../libressl-glibc.patch
+ "0" ../libressl-glibc.patch
diff --git a/libressl/v.mk b/libressl/v.mk
@@ -1 +1 @@
-v = 2.0.0
+v = 2.0.1