commit 56016cc3166795d91e53b789d57f87e220bd29f5
parent e0afff93b8244032e2baf2c3b5a4dcaf577377fb
Author: Hiltjo Posthuma <hiltjo@codemadness.org>
Date: Sun, 27 Apr 2014 17:46:37 +0000
add openssh
Signed-off-by: Hiltjo Posthuma <hiltjo@codemadness.org>
Diffstat:
5 files changed, 77 insertions(+), 0 deletions(-)
diff --git a/openssh/mkfile b/openssh/mkfile
@@ -0,0 +1,6 @@
+<$mkbuild/mk.3rdparty
+
+<v.mk
+src = openssh-$v
+url = http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-$v.tar.gz
+mkfile = ../openssh.mk
diff --git a/openssh/openssh-configure.patch b/openssh/openssh-configure.patch
@@ -0,0 +1,26 @@
+--- openssh-6.0p1/configure
++++ openssh-6.0p1.patched/configure
+@@ -7666,6 +7666,7 @@
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+ #include <stdio.h>
++#include <stdlib.h>
+ int
+ main ()
+ {
+@@ -10827,6 +10829,7 @@
+
+ #include <stdio.h>
+ #include <string.h>
++#include <stdlib.h>
+ #include <openssl/opensslv.h>
+ #define DATA "conftest.sslincver"
+
+@@ -10951,6 +10954,7 @@
+
+ #include <string.h>
+ #include <openssl/opensslv.h>
++#include <openssl/crypto.h>
+
+ int
+ main ()
diff --git a/openssh/openssh-sys_param.patch b/openssh/openssh-sys_param.patch
@@ -0,0 +1,10 @@
+--- openssh-6.5p1.org/sshd.c
++++ openssh-6.5p1/sshd.c
+@@ -44,6 +44,7 @@
+
+ #include "includes.h"
+
++#include <sys/param.h> /* MAXHOSTNAMELEN */
+ #include <sys/types.h>
+ #include <sys/ioctl.h>
+ #include <sys/socket.h>
diff --git a/openssh/openssh.mk b/openssh/openssh.mk
@@ -0,0 +1,34 @@
+TARG = openssh
+DEPS = zlib openssl
+
+<$mkbuild/mk.common-noinst
+
+openssh:QV:
+ export CFLAGS="$CFLAGS $DEPS_CFLAGS"
+ export LDFLAGS="$LDFLAGS $DEPS_LDFLAGS"
+ # fix implicit declarations
+ patch -p1 < ../openssh-configure.patch
+ patch -p1 < ../openssh-sys_param.patch
+ # prevent from installing some things (keysign and maybe others) setuid.
+ sed -i 's@-m 4711@-m 0750@g' Makefile.in
+ # work around for issue #104 until we come up with a proper patch
+ issue104cflags="-fno-builtin-exit -D__noreturn__="
+ CC="${CC} -static" \
+ CFLAGS="$issue104cflags -D_BSD_SOURCE -DMISSING_FD_MASK -DMISSING_NFDBITS $CFLAGS" \
+ ./configure -C --prefix="$prefix" \
+ --sbindir="$prefix"/bin --libexecdir="$prefix"/lib/ssh \
+ --sysconfdir="$prefix"/etc/ssh \
+ --with-privsep-user=nobody \
+ --with-md5-passwords --with-mantype=man --mandir="$prefix"/share/man \
+ --disable-strip --disable-lastlog --disable-utmp --disable-utmpx --disable-btmp \
+ --disable-wtmp --disable-wtmpx --disable-pututline --disable-pututxline
+ mkdir netinet
+ touch netinet/in_systm.h
+ sed -i '/USE_BTMP/d' config.h
+ sed -i '/USE_UTMP/d' config.h
+ sed -i 's@HAVE_DECL_HOWMANY 1@HAVE_DECL_HOWMANY 0@' config.h
+ make -j$nprocs
+
+install:QV:
+ make DESTDIR="$ROOT" install-nokeys
+
diff --git a/openssh/v.mk b/openssh/v.mk
@@ -0,0 +1 @@
+v = 6.5p1