commit 48ce21528409941fee0ec328e80d595f4bd933d1
parent eccc057f0148c99f847b61c448043e2f0c4e13d5
Author: Hiltjo Posthuma <hiltjo@codemadness.org>
Date: Sat, 7 Jun 2014 15:19:26 +0200
fix elinks on host build
Signed-off-by: Hiltjo Posthuma <hiltjo@codemadness.org>
Diffstat:
1 file changed, 7 insertions(+), 2 deletions(-)
diff --git a/elinks/elinks.mk b/elinks/elinks.mk
@@ -34,13 +34,18 @@ elinks:QV:
--enable-static
# fix warnings: sys/signal.h -> signal.h
find . -type f -name "*.[ch]" -exec sed 's@sys/signal.h@signal.h@g' -i {} \;
- # NOTE: LD is set to "ld", not gcc, because Makefile.lib specifies:
- # ld -r -o ...
+ # NOTES:
+ # - LD is set to "ld", not gcc, because Makefile.lib specifies:
+ # ld -r -o ...
+ # - X_CFLAGS is set to blank, it's set to "/usr/include" which breaks buils
+ # outside emul.
make -j$nprocs \
V="1" CC="${CC} -static" \
+ X_CFLAGS=" " \
LD="${TOOLCHAIN_TRIPLET}-ld" CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS"
install:QV:
make -j$nprocs install DESTDIR="$ROOT" \
V="1" CC="${CC} -static" \
+ X_CFLAGS=" " \
LD="${TOOLCHAIN_TRIPLET}-ld" CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS"