commit 3cccd53a4dacc03cb3d347e088f16e152c3d85a6
parent f2eefb72fc2dd1786ca37ac7c24afdcd3c7d7fcf
Author: Hiltjo Posthuma <hiltjo@codemadness.org>
Date: Sat, 12 Jul 2014 21:35:26 +0000
mutt: cross-compile and use libressl
Signed-off-by: Hiltjo Posthuma <hiltjo@codemadness.org>
Diffstat:
1 file changed, 11 insertions(+), 2 deletions(-)
diff --git a/mutt/mutt.mk b/mutt/mutt.mk
@@ -1,7 +1,7 @@
TARG = mutt
-DEPS = openssl ncurses
+DEPS = libressl ncurses
-INSTALL_MAN1 = `{ ls -1 doc/*.1}
+INSTALL_MAN1 = `{ ls -1 doc/*.1 }
INSTALL_BIN = mutt smime_keys pgpring pgpewrap
<$mkbuild/mk.common
@@ -9,7 +9,12 @@ INSTALL_BIN = mutt smime_keys pgpring pgpewrap
mutt:QV:
export CFLAGS="$CFLAGS $DEPS_CFLAGS"
export LDFLAGS="$LDFLAGS $DEPS_LDFLAGS"
+ # https://sourceware.org/bugzilla/show_bug.cgi?id=16698
+ test x"$arch" = x"arm" && export LDFLAGS="`printf "%s" \"$LDFLAGS\" | sed 's@-Wl,--gc-sections@@g'`"
+ #
CC="$CC" ./configure \
+ --build="${TOOLCHAIN_TRIPLET}" \
+ --host="${HOST_TOOLCHAIN_TRIPLET}" \
--prefix="$PREFIX" \
--mandir="$ROOT/share/man" \
--disable-shared \
@@ -19,4 +24,8 @@ mutt:QV:
--with-curses \
--with-mailpath="/var/spool/mail" \
--enable-static
+ # make doc/makedoc.c on host.
+ printf 'all:\n\ttrue\nclean:\n\ttrue' > doc/Makefile
+ $HOSTCC doc/makedoc.c -o doc/makedoc -D_GNU_SOURCE -D_BSD_SOURCE -DHAVE_STRERROR
+ #
make -j$nprocs