commit 3396f629f16b96de95762d8cb1c33242170de150
parent 7e2f5f0e29ccf30516db6587c5105d7113a5468e
Author: Hiltjo Posthuma <hiltjo@codemadness.org>
Date: Tue, 17 Jun 2014 21:41:55 +0200
libarchive: improve
- enable some things musl supports in config.h
- remove zlib_includedir from local_CFLAGS (DEPS_CFLAGS are passed).
Signed-off-by: Hiltjo Posthuma <hiltjo@codemadness.org>
Diffstat:
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/libarchive/config.h b/libarchive/config.h
@@ -455,7 +455,7 @@
/* #undef HAVE_LIBXML_XMLWRITER_H */
/* Define to 1 if you have the `z' library (-lz). */
-/* #undef HAVE_LIBZ */
+#define HAVE_LIBZ 1
/* Define to 1 if you have the <limits.h> header file. */
#define HAVE_LIMITS_H 1
@@ -688,7 +688,7 @@
#define HAVE_STRRCHR 1
/* Define to 1 if `f_namemax' is a member of `struct statfs'. */
-/* #undef HAVE_STRUCT_STATFS_F_NAMEMAX */
+#define HAVE_STRUCT_STATFS_F_NAMEMAX 1
/* Define to 1 if `f_iosize' is a member of `struct statvfs'. */
/* #undef HAVE_STRUCT_STATVFS_F_IOSIZE */
diff --git a/libarchive/libarchive.mk b/libarchive/libarchive.mk
@@ -12,7 +12,7 @@ cpio_cpio_OBJ = `{ls cpio/*.c | sed 's/.$/o/' | grep -v '_windows.o$'}
tar_tar_OBJ = `{ls tar/*.c | sed 's/.$/o/' | grep -v '_windows.o$'}
LOCAL_BIN_LDFLAGS = -L. -L${zlib_libdir} -lz -larchive -larchive_fe
-LOCAL_CFLAGS = -I. -I${zlib_includedir} -I. -Ilibarchive -Ilibarchive_fe -DHAVE_CONFIG_H
+LOCAL_CFLAGS = -I. -Ilibarchive -Ilibarchive_fe -DHAVE_CONFIG_H
<$mkbuild/mk.default