commit 1384d17e483213bca74fb42a298236363b0e216a
parent e68a0383282da7ac840c3b6ee35be9f7327ab43e
Author: Hiltjo Posthuma <hiltjo@codemadness.org>
Date: Sat, 7 Jun 2014 17:23:08 +0200
freetype: set harfbuzz flags to blank, options
Signed-off-by: Hiltjo Posthuma <hiltjo@codemadness.org>
Diffstat:
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/freetype/freetype.mk b/freetype/freetype.mk
@@ -9,6 +9,8 @@ freetype:QV:
# export LDFLAGS="$LDFLAGS $DEPS_LDFLAGS"
export ZLIB_CFLAGS="-I${zlib_includedir}"
export ZLIB_LIBS="-L${zlib_libdir} -lzlib"
+ export HARFBUZZ_CFLAGS=" "
+ export HARFBUZZ_LDFLAGS=" "
# needed because build system calls libpng-config.
export LIBPNG_CFLAGS="-I${libpng_includedir}"
export LIBPNG_LIBS="-L${libpng_libdir} -lpng16"
@@ -16,13 +18,12 @@ freetype:QV:
--prefix="$PREFIX" \
--mandir="$ROOT/share/man" \
--disable-shared \
- --disable-nls \
--enable-static \
--with-fsspec=no \
--with-fsref=no \
--with-bzip2=no \
--with-ats=no \
- --with-quickdraw-toolbo=no \
+ --with-quickdraw-toolbox=no \
--with-quickdraw-carbon=no \
--with-old-mac-fonts=no \
--with-harfbuzz=no \